Basic Excel Skills

3.1 INTRODUCTION

Excel may be the most versatile software program ever created. It is used daily by millions of people in every conceivable walk of life. Some of its users are simply adding up short columns of numbers, while others are creating sophisticated applications in which Excel is performing complex numerical calculations while interacting with several other software systems. With such a versatile and flexible tool, it is difficult for any user to determine just which of the thousands of features in Excel are really worth knowing. In this chapter, we describe the basic Excel skills we think are important for every business analyst.

This chapter is not intended to serve as a beginner’s tutorial on Excel. Those who are new to Excel and who need a tutorial should work through a book or a CD, or take an online course. Several of these are listed in the suggested readings. Those who have a working knowledge of Excel will find in this chapter some reminders about familiar tools and perhaps pointers to some new ones as well. We have found that many experienced users have never taken the time to explore Excel systematically, so their skills are deep in some areas but shallow in others. We recommend that you skim this chapter for Excel features that are new to you and add them to your skill set. A few minutes spent in learning how to use Excel more efficiently, even if you are an experienced user, can pay dividends in the future every time you build a spreadsheet model.

3.2 EXCEL PREREQUISITES

What spreadsheet skills are prerequisites for an analyst who would like to learn to model in Excel? The most basic skill, and one that doesn’t show up in the books, is the ability to learn by trial and error. Few successful users of software learn primarily from manuals or help facilities. Most have learned to scan the menus and search in a partly random, partly intelligent fashion for the tool they need and to experiment freely, knowing that (almost) nothing they do cannot be undone. In fact, the Undo command is one of the most important features in Excel!

Getting down to Excel, the first necessary skill is to be able to navigate around a worksheet and between worksheets in a workbook. This includes moving the cursor, scrolling, using the Home and End keys, and so on. Even the novice modeler needs to enter text and enter data and to choose the format of these entries. It is handy to be able to change the font name, style, and size; to use bold and italics; and to color a cell or its contents. The ability to edit the contents of a cell is important. Other necessary skills include inserting and deleting rows or columns and entire worksheets; cutting, copying, and pasting; printing; and drawing charts.

Skillful use of formulas and functions separates the novice spreadsheet user from the advanced user. To create formulas effectively, users must understand both relative cell addressing and absolute cell addressing. Excel has innumerable built-in functions that can drastically simplify calculations. Some of the most useful are SUM,
IF, MAX, MIN, AVERAGE, and NPV. The Insert Function window not only lists all the available functions by category, but also specifies the syntax of each function, explaining what inputs each requires and in what order.

Beyond these basic tools, Excel contains literally hundreds of specialized features. Few modelers use more than several dozens of these routinely, and even fewer can remember all of them between uses. It is not necessary to master all of these specialized tools in order to succeed at modeling.

We will use a simple spreadsheet model as an example throughout this chapter. The reader should open this model and use it to test out the features described below. The spreadsheet itself is shown in Figure 3.1.*

Potential investors in an office building construction project have asked us to evaluate this opportunity. Our task is to predict the after-tax cash flows resulting from constructing and operating this proposed office building over a five-year period. At a planned size of 180,000 square feet, the expected construction cost is $80 per square foot. The investors plan to take out a mortgage for 85 percent of the cost of the building (paying the remainder in cash), and they have been guaranteed a rate of 12 percent for a term of 30 years. The owners must also pay for the cost of operating the building, which includes taxes, insurance, maintenance, and certain utilities. They assume that the average operating cost per square foot will be $1.20. They have also estimated that they can charge a rental rate of $1.5 per square foot, with an occupancy rate of 70 percent. The cost of capital is 10 percent. Rents in the future are expected to grow 5 percent per year, while operating expenses grow 6 percent and the occupancy rate drops 4 percentage points yearly as the building ages. The owners plan to sell the building at the end of the fifth year for 12 times the final year’s net operating income.

---

**3.3 THE EXCEL WINDOW**

Each Excel file is called a *workbook*. A workbook consists of a number of individual *worksheets*. We will use the word “spreadsheet” to refer to both workbooks and worksheets.

The basic spreadsheet layout consists of a grid of rows and columns of cells (see Figure 3.2). The rows are labeled with numbers and the columns are labeled with letters. The maximum number of rows in a single worksheet is 1,048,576; the maximum number of columns is 16,384. The address of a cell corresponds to its column and row label—for example, C3 or AB567.

*To download spreadsheets for this chapter, go to the Student Companion Site at www.wiley.com/college/powell.
Excel displays on the computer screen a portion of this grid surrounded by other information. Some of the important features of the Excel window are described here and noted in Figure 3.2.

**Office Button**  The Office Button, which is located at the upper left corner of the window, provides access to the most commonly used commands such as New, Open, Close; Save, Save As; and Print. It also provides access to Excel Options.

**Quick Access Toolbar**  Just to the right of the Office Button is the Quick Access Toolbar. This toolbar provides a set of icons that provide shortcuts to frequently used commands. You can customize this toolbar by selecting the downward pointing arrow to the right of the icons.

**Tabs**  The main Excel commands are organized across the top row into the following tabs:

- Home
- Insert
- Page Layout
- Formulas
- Data
- Review
- View
- Add-ins

Additional tabs may, under certain conditions, appear to the right of the eight listed above.

**Ribbons and Groups**  Each tab gives access to a ribbon in which commands are organized into groups. For example, the Home tab has the following groups of commands:
- Clipboard
- Font
- Alignment
- Number
- Styles
- Cells
- Editing

The Font group includes the following commands:

- Font
- Font size (increase and decrease)
- Bold, italics, underline
- Borders
- Fill color
- Font color

In addition, the Font group includes a small downward-pointing arrow icon (\_\_) that opens the Format Cells window.

**Message Area**  When Excel performs lengthy calculations, a message will appear in this area giving information on the progress of the procedure.

**Scroll Bars**  These bars allow the user to change the portion of the spreadsheet displayed on the screen.

**Sheet Tabs**  These tabs allow the user to select which worksheet is displayed. The selection allows the user to move from sheet to sheet within a workbook.

**Tab-Scrolling Buttons**  These small triangles allow the display of different tabs in workbooks where not all of the tabs are visible at once.

**Name Box**  This box displays the cell address where the cursor is located, as well as the list of any named ranges. (Named ranges are covered in Chapter 4.)

**Formula Bar**  This box displays the contents of the cell where the cursor is located, whether a number, formula, or text. This is usually the area in which the user enters information into a cell.

**Mouse Cursor**  The location of the cursor is shown with an open cross symbol.

**Cell Cursor**  When a cell has been selected, it is outlined with a dark border. When a range of cells has been selected, it is colored blue and outlined with a dark border.

**Fill Handle**  At the lower right-hand corner of the cell border is a cross that can be selected for copying the contents of the cell to adjacent cells. When this cross is selected, the mouse cursor changes to a darkened cross.

---

**3.4 CONFIGURING EXCEL**

Many users are not aware that they can control the look and behavior of their spreadsheets by setting certain parameters. Select Office Button ➤ Excel Options, and a window appears with nine tabs listed in a column on the left (see Figure 3.3).
Except where noted below, most of the choices provided on these tabs can safely be left at their default values.

**Popular Tab**  Select an appropriate font and font size.

**Formulas Tab** In most uses, it is preferable to have the spreadsheet calculate all formula cells each time a change is made to any cell. This updating occurs if Automatic Calculation is selected under Calculation options. On occasion, it is useful to turn this feature off. To do so, check Manual Calculation. When the manual calculation option is chosen, the spreadsheet can be recalculated at any time by pressing F9, but it will not recalculate automatically when a cell is changed. The message “Calculate” will appear in the Message area when a cell has been changed but the spreadsheet has not been recalculated.

When a spreadsheet contains simultaneous relationships, calculations cannot be made in the usual manner. This situation typically generates an error message warning of a *circular reference*. This error message is useful because circular references usually occur when there is a mistake in the logic. However, there are circumstances where a circular reference is sensible (for example, when linking income statement and balance sheet models). In these cases, it is necessary to specify a number of iterations to calculate the desired values. Check the box labeled Enable iterative calculation to implement an iterative approach.

Under Error Checking check the box labeled Enable background error checking. Check all nine Error checking rules.

**Proofing Tab**  Select the preferred options for the AutoCorrect feature in Excel.

**Save Tab**  Check the box labeled Save AutoRecovery information so that Excel will automatically save your spreadsheets as often as specified.

**Advanced Tab**  Under Editing options, check the boxes labeled Enable fill handle and cell drag and drop, and Allow editing directly in cells.
Under Cut, copy, and paste, check the boxes labeled Show Paste Options buttons and Show Insert Options buttons.

Customize Tab: Customize the Quick Access Toolbar. Experienced Excel users will recognize that they use some commands quite frequently and instead of hunting for the commands in the ribbon, they can place the corresponding icon in the Quick Access Toolbar for convenience.

Add-ins Tab: View and manage add-ins.

Trust Center Tab: Information on privacy and security.

Resources Tab: Access to software updates and other information.

3.5 MANIPULATING WINDOWS AND SHEETS

Since most workbooks contain far more information than can be displayed on a computer screen, it is important to know how to display the most useful portion of the worksheet. The Zoom level (or magnification) of the worksheet can be set with a slider located at the lower right corner of the Excel window (see Figure 3.2). Alternatively, click on the 100% button to the left of the slider and the Zoom window opens (Figure 3.4). This window allows you to choose a preset or custom level of magnification. (The Zoom window can also be opened by selecting View ➤ Zoom ➤ Zoom.)

The View ➤ Window command makes it possible to simultaneously display more than one worksheet on the screen. These sheets may be from the same workbook or different workbooks. This command can be particularly useful when we are building formulas in one sheet using cells located in another. Select Window ➤ New Window to add a spreadsheet window, and then resize the new window and select the sheets to display, as in Figure 3.5.

Excel provides an option to split the screen horizontally, vertically, or both in order to display two sets of rows or columns in the same spreadsheet. If, for example, we wish to enter formulas in row 100 that reference cells in rows 1–10, we highlight row 10 and select View ➤ Window ➤ Split. Excel will open a second pane of rows with its own scroll bar, splitting the window horizontally. We can then display row 100 in the bottom pane while displaying rows 1–10 in the upper pane. The window can also be split vertically by highlighting a column. The window can even be split both horizontally and vertically by highlighting a cell. Figure 3.6 shows the worksheet split both horizontally and vertically at cell B13. (The screen can also be split by dragging the horizontal or vertical split bars, which are located just above and to the right of the row and column scroll bars, respectively.)

3.6 NAVIGATION

There are several ways to move the display from one portion of a spreadsheet to another. The horizontal and vertical scroll bars move the display of the portion of the entire spreadsheet that contains cell entries left and right or up and down,
respectively. However, the scroll bars cannot move the display to blank areas. This can be done by clicking on the scroll arrows above and below the vertical scroll bar and to the left and right of the horizontal scroll bar. We can also shift the display by clicking on a cell and highlighting a range that extends outside the display area.

The display area also can be moved by using the arrow keys (↑↓←→). If we hold one of these keys down, the cursor moves in the direction indicated until it reaches the limit of the display area, at which point the display shifts to keep the cursor on the screen. The Page Up and Page Down keys also shift the display up or down by a fixed number of rows. These keys are useful for quickly scanning the contents of a spreadsheet. (Other more complex ways of navigating a spreadsheet are covered in Chapter 4.)

Another way to navigate around a spreadsheet is to type a cell address into the Name Box (just above column A). When we press the Enter key, the cursor moves to the cell address we have entered and the display shifts to accommodate the
change. (If we use Names for cells or ranges of cells, they will appear in this box, and we can click on them to move the cursor. Range Names are covered in Chapter 4.) We can also use the Home ➤ Editing ➤ Find & Select ➤ Go To command to shift the cursor and display within a worksheet or to another worksheet.

### 3.7 SELECTING CELLS

There are many ways to select some or all of the cells in a spreadsheet. Here are the essentials. (More specialized methods are covered in Chapter 4.)

**Selecting All Cells in a Worksheet**  Click on the box immediately to the left of column A and above row 1.

**Selecting a Column or a Row**  Click on a single column label or a row label (for example, A or 1). To select several adjacent columns or rows, click on the first label and drag the cursor to the last label.

**Selecting Rectangular Ranges**  Any rectangular range of cells can be selected by selecting one of its four corner cells and dragging the cursor across to the diagonal corner. The same effect can be achieved by selecting a corner, dragging across the columns to the opposite corner and then across the rows to the diagonal corner, or vice versa.

**Selecting Noncontiguous Ranges**  To select two distinct rectangles of cells, select the first range, hold down the Control key, and select the second range. This method can be used to select three or more ranges as well.

### 3.8 ENTERING TEXT AND DATA

Information typed into a cell appears in two places: in the cell itself and in the formula bar. After we have clicked on Enter, we can edit the contents of the cell either by moving the cursor to the formula bar or by double-clicking on the cell and editing directly in the cell.

When we type letters into a cell, Excel automatically understands that the contents are text, and it left-justifies the contents in the cell. When we type in numbers, it recognizes the contents as numerical and right-justifies the contents.

To copy the contents of one cell to adjacent cells, we can either drag the Fill handle (the solid square at the lower right corner of the selected cell) over the adjacent cells, or else use Home ➤ Editing ➤ Fill ➤ Down (or Right, Up, Left).

We often need to enter a series of numbers or dates. Examples include the numbers of successive customers (1, 2, 3, 4, ...) or successive quarters in a year (Q1, Q2, Q3, ...). Excel provides several ways to enter these series quickly. The Home ➤ Editing ➤ Fill ➤ Series command will enter various kinds of series (see Figure 3.7). The same effect can be accomplished by entering the first two cell entries, highlighting them, and copying to the rest of the range using the Fill handle. Excel can usually guess the pattern.
correctly. For example, enter 1 and 2 in one column. Highlight the two cells. Fill down to the next eight cells using the Fill handle, and the remainder of the series (3, 4, 5, 6, 7, 8, 9, 10) will appear. To enter the numbers between 10 and 50 in steps of 5, enter 10 and 15 in adjacent cells and fill down until 50 is reached.

3.9 EDITING CELLS

There are several ways to edit the information in cells. Here are the most useful alternatives:

**Formula Bar** The simplest way to edit is to click on the Formula bar. A vertical cursor will appear in the Formula bar, and information can be entered or modified using all the normal Windows typing options. If the selected cell is not empty, its contents will appear in the Formula bar. Clicking on the text there will make the editing cursor appear.

**Double-Click** A handy alternative approach is to double-click on a cell, or equivalently, to press the F2 key. This allows editing in the cell itself. If the selected cell is not empty, any cells referred to in the formula will be highlighted in color, a useful debugging device. See Figure 3.8, where we have double-clicked on cell E19 and the formula in the cell is displayed. The four cell references used to calculate the result in cell E19 (C4, C5, C9, and C10) are highlighted in color, and a border with the matching color is drawn around each of those cells. Finally, the function used in the formula (ISPMT) is displayed below the cell, along with its arguments. If we click on the function name, the Help page for that function will appear.

We can modify the cell contents by inserting the vertical cursor where it is needed and typing directly into the cell or by moving the vertical cursor to the Formula bar and typing there. Alternatively, we can alter any cell reference in a formula by dragging the highlighted outline to another location. This option provides a visual device for editing, which is convenient when the formula is based on distinctive reference patterns.

**Insert Function** An alternative for editing a formula is Insert Function (the \( f_2 \) icon to the left of the Formula bar). If we click on this icon when the cursor is on a cell that does not contain a function, it will bring up the Insert Function window, which lists all available functions. If a specific function is then selected, it will be entered into the
formula, and its own window will appear, which facilitates entering the inputs properly. If we click on the \( f_x \) icon when the cursor is on a cell that already contains a function, it will bring up the corresponding function window, allowing the definition of the function to be verified or the arguments of the function to be revised. (More information on functions can be found in Section 3.12.)

**Absolute and Relative Cell References** A relative reference to cell C3 is simply “C3,” whereas an absolute reference is \( $C3 \). These types of references are useful primarily to make copying of complex formulas easy and reliable. Rather than typing in the appropriate dollar signs, it can be easier to enter all addresses in relative form (without dollar signs), highlight one or more addresses, and then press F4 repeatedly until the desired combination of absolute and relative references appears. (More information on formulas can be found in Section 3.11.)

### 3.10 FORMATTING

We can change individual column widths and row heights by moving the vertical or horizontal lines between the column and row labels. Widths or heights common to multiple columns or rows can be set using the Home ▶ Cells ▶ Format ▶ Cell Size ▶ Row Height/Column Width commands after highlighting the appropriate rows or columns. Alternatively, change one column width or one row height after highlighting the appropriate columns or rows.

Any range of cells can be formatted by highlighting the range and then selecting Home ▶ Cells ▶ Format ▶ Format Cells (or by selecting Home ▶ Font ▶ \( \text{\textbackslash{}_{\text{\textbackslash{}}} } \)). This opens a window with the following six tabs (see Figure 3.9):

**Number** Choose a type of formatting—for example, Currency or Date—and specify parameters such as the number of decimal places displayed.

**Alignment** Align text horizontally and vertically, and choose \texttt{Wrap Text} to fit long text labels into cells.

![The Format Cells Window](image)
Font Specify font, size, color, and superscript or subscript for the cell contents.

Border Set various borders around a range of cells.

Fill Set a background pattern or a color shade for the cell (but not its contents).

Protection Lock or hide cells for safety.

Many of these options are also available on the Home ribbon. The most frequently used icons on this ribbon are Increase Decimal and Decrease Decimal, which change the number of decimals displayed in selected cells by one decimal place each time they are clicked.

3.11 BASIC FORMULAS

Formulas in Excel provide the basic mechanism for entering the relationships in a model. In modeling terms, every cell in a spreadsheet that involves a formula is either an output of the model or an intermediate calculation needed to calculate an output.

With very few exceptions, well-written formulas contain no numbers, only cell references. Although it is often permissible to use numbers that never change in a formula, like the value 24 for the number of hours in a day, it is dangerous to embed parameters that may change in formulas. (In Chapter 5 we will see that isolating parameters is a feature of well-built spreadsheets.) Because formulas are built up from the values in other cells, they are written in terms of references to the contents of those cells.

Excel uses the following symbols for the basic arithmetic operations:

- Addition 
- Subtraction 
- Multiplication 
- Division
- Raise to a power

Excel formulas start with the equal sign (=) and are evaluated from left to right. However, arithmetic operations will be carried out in a specified order unless parentheses are used to control the calculation order. The basic arithmetic operations are calculated in the following order:

- Negation (as in −1)
- Exponentiation (°)
- Multiplication and division (× and ÷)
- Addition and subtraction (+ and −)

If a formula involves both multiplication and division (or both addition and subtraction), the leftmost of these operations is performed first.

Here are some examples that show how the calculation order and the use of parentheses can determine the outcome of a calculation:

- \(2 + 3/10 = 2.3\)
- \((2 + 3)/10 = 0.5\)
- \((2 + 3)/10^2 = 0.05\)
- \((2 + 3)/(10^2) = 0.05\)
- \(2 + 3/10^2 = 2.03\)
It is generally a good practice to use parentheses to make the meaning of a calculation clear and to ensure that it is calculated correctly.

When a formula is to be entered into just one cell, the references to its inputs can simply specify column and row, as for example, \((D2+D3)/D5\). The cell reference \(D2\) is an example of a relative reference. If the formula above was entered in cell \(E3\), then the reference to cell \(D2\) would be interpreted by Excel as referring to the cell one column to the left and one row above the current cell. That is, the cell reference is interpreted relative to the current cell. Likewise, from cell \(E3\), a reference to \(J14\) is interpreted as a reference to the cell 5 columns to the right and 11 rows down.

Many spreadsheets are built by copying formulas from one cell to a range of cells. For example, row 18 in the Office Building spreadsheet (Net Operating Income) requires subtracting Operating Income from Gross Income each year. Thus the formula entered into cell \(C18\) (\(C16-C17\)) is the same formula that we need in the following years, cells \(D18-G18\). We can fill these four cells efficiently by entering the formula once in cell \(C18\) and then copying it to the other cells. Because Excel interprets the cell addresses \(C16\) and \(C17\) relative to the current cell, when we copy the formula, it continues to apply correctly.

However, this same procedure will not work for row 17, in which we calculate Operating Expense. The Operating Expense for Year 1 is the size of the building in square feet (\(C5\)) times the cost per square foot (\(C7\)). Thus we could calculate the correct value in \(C17\) using the formula \(C5*C7\). But the Operating Expense in the next year, Year 2, is not calculated in the same way. The size of the building is fixed for all time in \(C5\), but the cost per square foot grows each year as given in cells \(D7-G7\). So the correct formula in cell \(D17\) is \(C5*D7\). In other words, one of the addresses in the original formula (\(C5\)) needs to remain fixed, while the other (\(C7\)) needs to shift from year to year. Clearly, we need a way to write a cell address so that Excel will interpret it not in a relative fashion but as fixed. This is done using dollar signs before the column letter and row number, as in \($C$5\). The first dollar sign fixes the column during copying; the second dollar sign fixes the row. So, if we write the original formula in cell \(C17\) as \($C$5*$C7\), which does not change the value in \(C17\), we can then copy it across the row correctly. The reference to the size of the building in \(C5\) will remain fixed, and the reference to the cost will change as needed. Addresses with fixed columns or rows are known as absolute addresses. Examine all the formulas in the Office Building spreadsheet to see how relative and absolute addresses are used to make copying easy.

### 3.12 Basic Functions

Excel provides hundreds of built-in functions for calculating almost anything. No matter how complex or unusual the calculation we have in mind, Excel almost always has a function (or perhaps several functions) that can accomplish the task. Using Excel functions presents three challenges:

- Identifying the appropriate function or functions
- Using the function correctly
- Testing that the results match what was intended.

An efficient way to locate useful functions is to open the Insert Function window by clicking \(f_{x}\) next to the formula bar. (The Insert Function window can also be accessed from the Formulas ribbon.) Figure 3.10 shows the Insert Function window with the category Financial selected. The drop-down menu displays a list of function categories. The major categories are as follows:

- Most Recently Used
- All
- Financial
- Date & Time
- Math & Trig
- Statistical
- Lookup & Reference
- Database
- Text
- Logical
- Information

To find a function, first identify the category it is likely to fall into, and then scan the alphabetical list of functions in this category. Each time a function is highlighted, the Insert Function window displays a brief description of the function and its inputs. For example, in Figure 3.11 we have highlighted the financial function IFSMT. The window displays its inputs (rate, per, nper, pv) and gives a short description: Returns the interest paid during a specific period of an investment.
At this point, click on OK and the Function Arguments window opens (Figure 3.12). This window displays a reference box for each of the arguments of the function (four in this case). We can either enter numbers directly in these boxes or (better) enter cell addresses (click on the icon at the right end of the box and identify the inputs by selecting them in the spreadsheet). The Function Arguments window shows the numerical value of each input as it is entered, and when enough inputs are entered, the window shows the value of the function. This allows us to see if we are getting plausible results before entering the function in the spreadsheet. (Help on this specific function is also available directly from the link at the bottom of this window.) Figure 3.13 shows the Function Arguments window with all four inputs entered and the result calculated (−122,060). Click on OK and the function will be entered in the cell we are editing.

Business analysts make heavy use of just a few of the hundreds of functions in Excel. We will describe six of the most important of these functions here. Other useful functions are described in Chapter 4.

The SUM function is used to add a set of numbers. Its arguments can simply be a list of cell references. For example, SUM(C1, C3, C5) adds the contents of the three cells listed, where the cell references are set off by commas. Alternatively, SUM(C1:C5) adds the contents of the cells in the range C1:C5. The SUM function can also be used to add a list of noncontiguous ranges, for example, SUM(C1:C5, D2:D6, E3:E7).

The MAX and MIN functions are used to find the largest and smallest values in a range. Thus MAX(1, 3, 5) yields 5, and MIN(C1:C5) calculates the smallest value in the range C1:C5.

The AVERAGE function calculates the average of the values in a range. The range can be in a column, in a row, or in an array (a rectangular range extending over
multiple columns and/or rows). If we are averaging a column of data that contains empty cells, does the AVERAGE function include those cells in the calculation? Click on Help in the Function Arguments window and note that the AVERAGE function ignores cells containing text, logical values (True or False), and empty cells, but does include cells containing the value zero.

The NPV function calculates the net present value of a stream of payments at a given discount rate. We illustrate the use of the NPV function in the Office Building spreadsheet. In this example, we make a down payment of $2,160,000 at the present time, the start of Year 1 (cell C22). Then we receive cash inflows at the end of the next five years (cells C25:G25). To calculate the net present value of this set of payments (cell B27), we discount the cash inflows to the present, using the discount rate given in cell C12, and subtract the down payment (since it occurs at the present time, it is not discounted). The formula is

$$\text{NPV}(C12, C25:G25) - C22$$

The Function Arguments window (Figure 3.14) shows the cell addresses of the arguments of the NPV function as well as their numerical values. It also shows the resulting value of the NPV calculation ($13,632,032.03$), as well as the value of the entire formula ($11,472,032$).

It is important to remember that the NPV function discounts the first payment in a stream of payments. Thus in the Office Building example, we discounted the cash inflow in Year 1 because according to the model, it comes in at the end of the year and the date of the evaluation is the beginning of the year. If, instead, the first cash inflow occurred at the beginning of the year, at the same time as the down payment, we would discount with the NPV function starting with Year 2 and add the undiscounted cash inflow from Year 1.

The IF function is used to perform a logical test and calculate one value if the test is true and another if it is false. The syntax for the IF function is

$$\text{IF(logical test, value-if-true, value-if-false)}$$

The first argument, the logical test, is an expression that Excel can evaluate as TRUE or FALSE. For example, the expression 100 \(>\) 0 evaluates as TRUE, while 100 \(>\) 200 evaluates as FALSE. (For practice, go to the Office Building spreadsheet and enter the formula =C4 \(>\) 0 in an empty cell. The result should be TRUE. The formula =E16 \(>\) 5,000,000 should be FALSE.)

If the logical test in an IF statement is TRUE, the second argument (value-if-true) is calculated and placed in the cell. If the logical test is FALSE, the third argument (value-if-false) is calculated and placed in the cell. For example, IF (100 \(>\) 0, 25, 50) evaluates as 25, and IF (100 \(<\) 0, 25, 50) evaluates as 50. Each of the three arguments in

![Figure 3.14: The NPV Function](image-url)
an IF function can be as complex as needed, as long as Excel can evaluate the logical test as TRUE or FALSE. So we could write the following function to choose one of two column sums, depending on the relative values of two other cells:

\[
\text{IF(D36 > G76, SUM(A1:A100), SUM(B1:B100))}
\]

This example illustrates the nesting of functions. Nesting involves using one function within another. So in the example above, we have nested two SUM functions within an IF function. Excel imposes no practical limit on the number of functions that can be nested. However, nested functions can become complex and difficult to debug. It is good practice to calculate the components of a complex nested function separately to ensure that the logic is correct before bringing them together. And remember that future users of the model will appreciate documentation of formulas like the following one, whose meaning is not transparent:

\[
\text{IF(D345 < I87, OFFSET(G118, MAX(I87:J129) - I86), -H45)}
\]

### 3.13 CHARTING

Charting is an essential skill for the business analyst, because model results can often best be understood in graphical terms. Excel provides tools that automate much of the detailed work involved in developing a chart. Charts are created by selecting the Insert tab and the Charts group.

The first step in creating a chart is to highlight the relevant data on the spreadsheet. Then select Insert ▶ Charts. Next select the type of chart (Column, Line, Pie, Bar, Area, Scatter, or Other Charts). A window then opens showing a variety of ways to depict that type of chart. Select one of these and Excel will plot the data in that format.

Note that when Excel displays a chart, it adds three Chart Tools tabs to the ribbon (Design, Layout, and Format). These tabs also appear whenever an existing chart is selected. The Design tab includes the following groups:

- Type
- Data
- Chart Layouts
- Chart Styles
- Location

The Type group allows a change in the chart type or saves the current chart as a template. The Data group allows data rows and columns to be swapped or the data range to be modified. Chart Layouts includes a variety of chart layouts for titles, axes, and so on. Chart Styles offers a variety of colors and shades. Finally, the Location group helps move the chart to a desired location.

We illustrate two types of frequently used charts: line charts and scatter charts. The data involve advertising and sales over the past 11 years, as given in the table. A line chart allows us to see how Advertising and Sales have changed over the past 11 years, while a scatter chart allows us to see whether Advertising and Sales are related to each other.

<table>
<thead>
<tr>
<th>Year</th>
<th>Advertising</th>
<th>Sales</th>
</tr>
</thead>
<tbody>
<tr>
<td>1995</td>
<td>56</td>
<td>600</td>
</tr>
<tr>
<td>1996</td>
<td>56</td>
<td>630</td>
</tr>
</tbody>
</table>
To create a line chart for Advertising and Sales over time, highlight all the data in the spreadsheet (including the column headings) and select Insert ➤ Chart. Choose the Line chart type and the 2D-Line subtype that shows each data point (Line with Markers), as shown in Figure 3.15. This chart is problematic because the years have been plotted as a data series rather than the X-axis values. To correct this, and to ensure that Years are on the horizontal axis, select Design ➤ Data ➤ Select Data. Under Legend Entries (Series) highlight Year and click on Remove. Also, under Horizontal (Category) Axis Labels click on Edit and enter the range for years: $C5:C15$. Click on OK and the chart will appear as in Figure 3.16. Clearly, Sales have increased steadily over this period. A close look reveals that the same is true for Advertising.

We can continue to refine this chart, using the options under Chart Layouts and Chart Styles. Our final version, shown in Figure 3.17, has an overall title, a Y-axis label, and a key showing the exact values for each data point. This is just one of the 11 predefined options under Chart Layouts.
To create a scatter chart, highlight just the Advertising and Sales data and select Insert ➤ Chart ➤ Scatter ➤ Scatter with only Markers. The result is shown in Figure 3.18. This graph is correct, but it does not display the data in the clearest fashion because the axis scales are inappropriate. We change the horizontal axis scale by right-clicking in the Chart Area, selecting Format Chart Axis, and setting the minimum value under Axis Options to 50. Repeat this process for the vertical axis, setting the minimum to 500 and the maximum to 1,000. The improved chart is shown in Figure 3.19.
This chart conveys a different message from the line chart. Here, we see that higher levels of Advertising seem to be associated with higher levels of Sales, which perhaps suggests that Advertising is effective in increasing Sales. But the relationship may be influenced by other factors, since the scatter plot is not a straight line.

3.14 PRINTING

Printing in Excel is similar to printing in any Office application, with a few exceptions we discuss here.

First, many spreadsheets contain too much information to print on a single page. Depending on the column width and row height, Excel will select a range of cells to print on each page. Open the Office Building spreadsheet and select Office Button ➤ Print ➤ Print Preview. Excel displays the spreadsheet as it will look when printed. Click on Close Print Preview and note that Excel has divided the spreadsheet into pages with heavy dotted lines. The first page extends from A1 to E52, the second page from A53 to E104, and so on.

We can select certain cells for printing by highlighting the relevant range and selecting Page Layout ➤ Page Setup ➤ Print Area ➤ Set Print Area.

We display the Page Setup window by selecting Page Layout ➤ Page Setup. Figure 3.20 shows the Page Setup window, which allows us to control other aspects of the printed page. For example, on the Page tab we can change the orientation of the printed spreadsheet from Portrait to Landscape. We can also change the scaling on this tab. A particularly useful option here is the button that fits a worksheet to a specified number of pages. Quite often, the number of pages is set to 1 for a scaled snapshot of the entire worksheet. On the Margins tab, we can alter the top, bottom, left, and right margins and the location of the contents on the page. Using the Header/Footer tab, we can enter text that will appear on every printed page, such as a page number or the name of the author of the workbook. Moreover, on the Sheet tab we can control whether gridlines and row and column headings will appear on the printed spreadsheet.
3.15 HELP OPTIONS

A great deal of useful information is available in Excel Help, which is opened by either pressing F1 or clicking on the question mark icon in the upper right corner of the spreadsheet (Figure 3.21).

Excel also offers access to targeted Help topics in a variety of specific situations. For example, some dialog boxes show a question mark at the right-hand end of the title bar. Click on the question mark and Excel opens the Help window for the operation controlled by the window. In other windows, there is a special link to Help. For example, the Insert Function window has a link to Help on this function, which opens the Help window for the function highlighted.

3.16 SUMMARY

Excel is both a highly versatile and a highly complex computer application. Not only can it be used for routine calculation, but it can also be used for complex decision support tasks. Each user must determine how many of the thousands of Excel features are needed on the job. This chapter presents the basic Excel skills every business analyst should have.

This chapter covers these basic features of Excel:

- The Excel window
- Configuring Excel
- Manipulating windows and sheets
- Navigation
- Selecting cells
- Entering text and data
- Editing cells
- Formatting
- Basic formulas
- Basic functions
- Charting
- Printing
- Help
SUGGESTED READINGS

Books


  This book covers the fundamentals of Excel as well as some advanced features, such as macros and data analysis.


  This is an elementary workbook. Chapters A through E are essential. The remaining chapters are quite advanced and can be omitted by the beginner.


  This book contains the previous one. Its additional chapters make it a handy reference manual.

Compact Disk


  This CD focuses on Excel skills useful in analyzing business problems. It consists of nine modules, starting with Excel menus and moving through more advanced topics, including Solver, graphing, regression, and pivot table.

Online Programs

Online courses in Excel 2007 are available from the following sources:

- ElementK: www.elementk.com
- CustomGuide: www.customguide.com
- Microsoft Office Online: http://office.microsoft.com
- RemoteCourse: http://www remotecourse.com